Partial network outage in BA building
Incident Report for Utah Valley University
Resolved
This has been resolved. Please contact the Service Desk if you continue to experience any issues.
Posted Mar 04, 2020 - 14:09 MST
Identified
There is a partial network outage in the BA building. It is being worked on. We will provide an update when we have more information.
Posted Mar 04, 2020 - 11:39 MST
This incident affected: General IT Services.