my.uvu Outage
Incident Report for Utah Valley University
Resolved
myUVU is working well again. Please contact the Service Desk if you experience further issues.
Posted Jan 14, 2021 - 00:58 MST
Monitoring
A fix has been applied to myUVU. We will continue to monitor this closely.
Posted Jan 13, 2021 - 21:46 MST
Identified
We have identified an issue which prevents logging into myUVU. Updates will be provided as we learn more.
Posted Jan 13, 2021 - 21:34 MST
This incident affected: myUVU Services (myUVU General Services, myUVU Student Services, myUVU Employee Services).