registration outage
Incident Report for Utah Valley University
Resolved
We have resolved the registration outage. Please contact the Service Desk if you are experiencing further issues.
Posted Dec 02, 2020 - 15:55 MST
Identified
We have identified a Registration outage affecting all students. Updates will be provided as we learn more.
Posted Dec 02, 2020 - 09:24 MST
This incident affected: myUVU Services (myUVU Student Services).