Login Outage Affecting myUVU, Canvas, and Other Services
Incident Report for Utah Valley University
Resolved
The login outage affecting myUVU, Canvas, and other services has been resolved. We will continue to monitor login services closely.
Posted Oct 17, 2020 - 00:57 MDT
Monitoring
A fix has been applied and login should be available again on myUVU, Canvas, and other services. We will continue to monitor login services closely.
Posted Oct 17, 2020 - 00:36 MDT
Investigating
We are investigating reports of a login outage affecting myUVU, Canvas, and other services. Updates will be provided as we learn more.
Posted Oct 17, 2020 - 00:13 MDT
This incident affected: Teaching, Learning, & Classrooms (Canvas), Software, Websites & Apps (myUVU), and General IT Services.