myUVU: Personal Contact info
Incident Report for Utah Valley University
Resolved
This problem has been resolved.
Posted Jul 06, 2020 - 14:50 MDT
Monitoring
A fix has been applied for this issue. Please refresh your browser and log in again to access Personal Contact Information in myUVU.
Posted Jul 06, 2020 - 13:31 MDT
Investigating
Users are currently unable to access the Personal Contact Information link in myUVU. We are currently looking into this issue and will report back when we know more.
Posted Jul 06, 2020 - 13:12 MDT
This incident affected: myUVU Services (myUVU General Services).