IT Services Catalog 404 Page not Found
Incident Report for Utah Valley University
Resolved
Posted Jul 09, 2020 - 13:54 MDT
Investigating
When accessing the IT Services Catalog, users are getting a 404 Page Not Found error. We are working to resolve the issue, and will update when we learn more. As an immediate work around, please use https://www.uvu.edu/itservices/.
Posted Jul 09, 2020 - 10:52 MDT